1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-01 01:18:54 +03:00

[lantiq] fix gptu patch - tapi should now load

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34777 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2012-12-18 20:12:57 +00:00
parent 9cd3628d46
commit e34d85e181

View File

@ -1,50 +1,7 @@
Index: linux-3.7-rc8/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
===================================================================
--- linux-3.7-rc8.orig/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h 2012-12-13 10:34:27.044276614 +0100
+++ linux-3.7-rc8/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h 2012-12-13 10:41:34.332287326 +0100
@@ -90,5 +90,8 @@
extern void ltq_pmu_enable(unsigned int module);
extern void ltq_pmu_disable(unsigned int module);
+/* allow tapi driver to read the gptu value */
+long gptu_get_count(struct clk *clk);
+
#endif /* CONFIG_SOC_TYPE_XWAY */
#endif /* _LTQ_XWAY_H__ */
Index: linux-3.7-rc8/arch/mips/lantiq/xway/gptu.c
===================================================================
--- linux-3.7-rc8.orig/arch/mips/lantiq/xway/gptu.c 2012-12-13 10:34:27.044276614 +0100
+++ linux-3.7-rc8/arch/mips/lantiq/xway/gptu.c 2012-12-13 10:34:30.564276702 +0100
@@ -105,8 +105,11 @@
gptu_w32(CON_CNT | CON_EDGE_ANY | CON_SYNC | CON_CLK_INT,
GPTU_CON(clk->bits));
gptu_w32(1, GPTU_RLD(clk->bits));
- gptu_w32(gptu_r32(GPTU_IRNEN) | BIT(clk->bits), GPTU_IRNEN);
+/* gptu_w32(gptu_r32(GPTU_IRNEN) | BIT(clk->bits), GPTU_IRNEN);*/
gptu_w32(RUN_SEN | RUN_RL, GPTU_RUN(clk->bits));
+
+ printk("%s:%s[%d]%X %X %X\n", __FILE__, __func__, __LINE__, gptu_r32(GPTU_CON(clk->bits)), gptu_r32(GPTU_RLD(clk->bits)), gptu_r32(GPTU_RUN(clk->bits)));
+
return 0;
}
@@ -119,6 +122,12 @@
free_irq(irqres[clk->bits].start, NULL);
}
+long gptu_get_count(struct clk *clk)
+{
+ return gptu_r32(GPTU_CNT(clk->bits));
+}
+EXPORT_SYMBOL_GPL(gptu_get_count);
+
static inline void clkdev_add_gptu(struct device *dev, const char *con,
unsigned int timer)
{
Index: linux-3.7-rc8/arch/mips/lantiq/xway/timer.c
Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.7-rc8/arch/mips/lantiq/xway/timer.c 2012-12-13 10:41:16.360286872 +0100
+++ linux-3.7.1/arch/mips/lantiq/xway/timer.c 2012-12-18 20:47:56.625037132 +0100
@@ -0,0 +1,841 @@
+#include <linux/kernel.h>
+#include <linux/module.h>
@ -887,10 +844,10 @@ Index: linux-3.7-rc8/arch/mips/lantiq/xway/timer.c
+
+module_init(lq_gptu_init);
+module_exit(lq_gptu_exit);
Index: linux-3.7-rc8/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
Index: linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.7-rc8/arch/mips/include/asm/mach-lantiq/lantiq_timer.h 2012-12-13 10:34:30.564276702 +0100
+++ linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h 2012-12-18 20:47:56.625037132 +0100
@@ -0,0 +1,155 @@
+#ifndef __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
+#define __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
@ -1047,3 +1004,12 @@ Index: linux-3.7-rc8/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
+ u32 reload, unsigned long arg1, unsigned long arg2);
+
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
===================================================================
--- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile 2012-12-18 20:48:40.717038183 +0100
+++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2012-12-18 20:49:10.129038884 +0100
@@ -1,3 +1,3 @@
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o