mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 16:10:39 +02:00
madwifi: Fix linux 3.0 detection
Allows madwifi to be built against linux 3.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27188 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
58dfdd9138
commit
e6f792889d
25
package/madwifi/patches/476-3.0_detection_fix.patch
Normal file
25
package/madwifi/patches/476-3.0_detection_fix.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -155,13 +155,15 @@ unload:
|
||||
configcheck:
|
||||
@echo -n "Checking kernel configuration... "
|
||||
|
||||
- @# check version of kernel
|
||||
- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
|
||||
- echo "FAILED"; \
|
||||
- echo "Only kernel versions 2.4.x and above are supported."; \
|
||||
- echo "You have $(KERNELRELEASE)."; \
|
||||
- exit 1; \
|
||||
- }
|
||||
+ @# check kernel version
|
||||
+ @case $(KERNELRELEASE) in \
|
||||
+ 2.[456].*) ;; \
|
||||
+ [3-9].*) ;; \
|
||||
+ *) echo "FAILED"; \
|
||||
+ echo "Only kernel versions 2.4.x and above are supported."; \
|
||||
+ echo "You have $(KERNELRELEASE)."; \
|
||||
+ exit 1 ;; \
|
||||
+ esac
|
||||
|
||||
@# check kernel configuration
|
||||
@if [ -z "$(CONFIG_SYSCTL)" ]; then \
|
Loading…
Reference in New Issue
Block a user