1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 20:31:07 +03:00

[tools] bison: make yacc wrapper relocatable

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29831 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-01-20 17:30:38 +00:00
parent 4edf16ce2b
commit eb4bd61e1b

View File

@ -0,0 +1,20 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -77,6 +77,7 @@ MOSTLYCLEANFILES = yacc
yacc:
echo '#! /bin/sh' >$@
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
chmod a+x $@
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -1352,6 +1352,7 @@ uninstall-am: uninstall-binPROGRAMS unin
yacc:
echo '#! /bin/sh' >$@
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
chmod a+x $@