1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 16:35:27 +03:00

Remove host include search pathes from Makefiles

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1072 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2005-05-27 05:15:40 +00:00
parent 6cf14b7f88
commit f06fa034da
3 changed files with 44 additions and 15 deletions

View File

@ -1,15 +0,0 @@
--- ulogd-1.23/pcap/Makefile.in.orig 2004-03-23 23:36:04.000000000 +0100
+++ ulogd-1.23/pcap/Makefile.in 2005-05-16 00:14:13.000000000 +0200
@@ -14,10 +14,10 @@
distrib:
$(SHARED_LIBS): %.so: %_sh.o
- $(LD) -shared -o $@ $< -lc -lpcap
+ $(LD) -shared $(PCAP_LDFLAGS) -o $@ $< -lc -lpcap
%_sh.o: %.c
- $(CC) $(SH_CFLAGS) -o $@ -c $<
+ $(CC) $(PCAP_CFLAGS) $(SH_CFLAGS) -o $@ -c $<
clean:
$(RM) $(SHARED_LIBS) *.o

View File

@ -0,0 +1,24 @@
diff -ruN ulogd-1.23-old/Rules.make.in ulogd-1.23-new/Rules.make.in
--- ulogd-1.23-old/Rules.make.in 2005-02-19 22:32:40.000000000 +0100
+++ ulogd-1.23-new/Rules.make.in 2005-05-27 07:45:18.000000000 +0200
@@ -22,7 +22,7 @@
CFLAGS+=-DULOGD_CONFIGFILE=\"$(ULOGD_CONFIGFILE)\"
# doesn't work for subdirs
#CFLAGS+=$(INCIPULOG) $(INCCONFFILE)
-CFLAGS+=-I/lib/modules/`uname -r`/build/include
+#CFLAGS+=-I/lib/modules/`uname -r`/build/include
#CFLAGS+=@DEFS@
#CFLAGS+=-g -DDEBUG -DDEBUG_MYSQL -DDEBUG_PGSQL
diff -ruN ulogd-1.23-old/libipulog/Makefile.in ulogd-1.23-new/libipulog/Makefile.in
--- ulogd-1.23-old/libipulog/Makefile.in 2004-03-23 23:36:06.000000000 +0100
+++ ulogd-1.23-new/libipulog/Makefile.in 2005-05-27 07:44:21.000000000 +0200
@@ -1,7 +1,7 @@
#
include @top_srcdir@/Rules.make
-CFLAGS+=-Iinclude -I/usr/src/linux/include
+CFLAGS+=-Iinclude
libipulog.a: libipulog.o
$(LD) -i $< -o $@

View File

@ -0,0 +1,20 @@
diff -ruN ulogd-1.23-old/ulogd.conf.in.rej ulogd-1.23-new/ulogd.conf.in.rej
--- ulogd-1.23-old/ulogd.conf.in.rej 2005-04-18 16:19:06.000000000 +0200
+++ ulogd-1.23-new/ulogd.conf.in.rej 1970-01-01 01:00:00.000000000 +0100
@@ -1,16 +0,0 @@
-***************
-*** 62,68 ****
- user="laforge"
- db="ulogd"
- host="localhost"
-- use_ssl=0
-
- [PGSQL]
- table="ulog"
---- 62,67 ----
- user="laforge"
- db="ulogd"
- host="localhost"
-
- [PGSQL]
- table="ulog"