mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:01:52 +02:00
[adm5120] add support for the OSBRiDGE 5GXi/5XLi (thanks to Mattia Aracne for the board)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16555 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0b11037830
commit
f6eb698b63
@ -130,6 +130,12 @@ config ADM5120_MACH_PMUGW
|
||||
select ADM5120_OEM_MOTOROLA
|
||||
default y
|
||||
|
||||
config ADM5120_MACH_5GXI
|
||||
bool "OSBRiDGE 5GXi/5XLi support"
|
||||
select ADM5120_SOC_BGA
|
||||
select ADM5120_OEM_OSBRIDGE
|
||||
default y
|
||||
|
||||
config ADM5120_MACH_P_334WT
|
||||
bool "ZyXEL Prestige 334WT"
|
||||
depends on CPU_BIG_ENDIAN
|
||||
@ -168,6 +174,9 @@ config ADM5120_OEM_MIKROTIK
|
||||
config ADM5120_OEM_MOTOROLA
|
||||
def_bool n
|
||||
|
||||
config ADM5120_OEM_OSBRIDGE
|
||||
def_bool n
|
||||
|
||||
config ADM5120_OEM_ZYXEL
|
||||
def_bool n
|
||||
|
||||
|
@ -68,6 +68,8 @@ static struct board_desc common_boards[] __initdata = {
|
||||
DEFBOARD("153", MACH_ADM5120_RB_153),
|
||||
DEFBOARD("192", MACH_ADM5120_RB_192),
|
||||
DEFBOARD("miniROUTER", MACH_ADM5120_RB_150),
|
||||
/* OSBRiDGE boards */
|
||||
DEFBOARD("OSBRiDGE 5GXi", MACH_ADM5120_5GXI),
|
||||
/* Motorola boards */
|
||||
DEFBOARD("Powerline MU Gateway",MACH_ADM5120_PMUGW),
|
||||
};
|
||||
|
75
target/linux/adm5120/files/arch/mips/adm5120/osbridge/5gxi.c
Normal file
75
target/linux/adm5120/files/arch/mips/adm5120/osbridge/5gxi.c
Normal file
@ -0,0 +1,75 @@
|
||||
/*
|
||||
* OSBRiDGE 5GXi/5XLi board support
|
||||
*
|
||||
* Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU General Public License version 2 as published
|
||||
* by the Free Software Foundation.
|
||||
*
|
||||
*/
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/gpio.h>
|
||||
#include <linux/irq.h>
|
||||
#include <linux/etherdevice.h>
|
||||
|
||||
#include <asm/mips_machine.h>
|
||||
|
||||
#include <asm/mach-adm5120/adm5120_defs.h>
|
||||
#include <asm/mach-adm5120/adm5120_platform.h>
|
||||
#include <asm/mach-adm5120/adm5120_info.h>
|
||||
|
||||
#ifdef CONFIG_MTD_PARTITIONS
|
||||
static struct mtd_partition osbridge_5gxi_partitions[] = {
|
||||
{
|
||||
.name = "bootloader",
|
||||
.offset = 0,
|
||||
.size = 64*1024,
|
||||
.mask_flags = MTD_WRITEABLE,
|
||||
} , {
|
||||
.name = "boardcfg",
|
||||
.offset = 64*1024,
|
||||
.size = 64*1024,
|
||||
} , {
|
||||
.name = "firmware",
|
||||
.offset = MTDPART_OFS_APPEND,
|
||||
.size = MTDPART_SIZ_FULL,
|
||||
}
|
||||
};
|
||||
#endif /* CONFIG_MTD_PARTITIONS */
|
||||
|
||||
static struct gpio_led osbridge_5gxi_gpio_leds[] __initdata = {
|
||||
GPIO_LED_INV(ADM5120_GPIO_PIN6, "5gxi:green:user", NULL),
|
||||
GPIO_LED_INV(ADM5120_GPIO_P0L0, "5gxi:yellow:lan", NULL),
|
||||
};
|
||||
|
||||
static struct adm5120_pci_irq osbridge_5gxi_pci_irqs[] __initdata = {
|
||||
PCIIRQ(2, 0, 1, ADM5120_IRQ_PCI0),
|
||||
};
|
||||
|
||||
static u8 osbridge_5gxi_vlans[6] __initdata = {
|
||||
0x41, 0x00, 0x00, 0x00, 0x00, 0x00
|
||||
};
|
||||
|
||||
static void __init osbridge_5gxi_setup(void)
|
||||
{
|
||||
#ifdef CONFIG_MTD_PARTITIONS
|
||||
adm5120_flash0_data.nr_parts = ARRAY_SIZE(osbridge_5gxi_partitions);
|
||||
adm5120_flash0_data.parts = osbridge_5gxi_partitions;
|
||||
#endif /* CONFIG_MTD_PARTITIONS */
|
||||
|
||||
adm5120_add_device_uart(0);
|
||||
adm5120_add_device_uart(1);
|
||||
|
||||
adm5120_add_device_flash(0);
|
||||
|
||||
adm5120_add_device_switch(1, osbridge_5gxi_vlans);
|
||||
adm5120_add_device_gpio_leds(ARRAY_SIZE(osbridge_5gxi_gpio_leds),
|
||||
osbridge_5gxi_gpio_leds);
|
||||
adm5120_pci_set_irq_map(ARRAY_SIZE(osbridge_5gxi_pci_irqs),
|
||||
osbridge_5gxi_pci_irqs);
|
||||
}
|
||||
|
||||
MIPS_MACHINE(MACH_ADM5120_5GXI, "OSBRiDGE 5GXi/5XLi board",
|
||||
osbridge_5gxi_setup);
|
@ -0,0 +1 @@
|
||||
obj-$(CONFIG_ADM5120_MACH_5GXI) += 5gxi.o
|
@ -1,5 +1,5 @@
|
||||
/*
|
||||
* Copyright (C) 2007-2008 Gabor Juhos <juhosg@openwrt.org>
|
||||
* Copyright (C) 2007-2009 Gabor Juhos <juhosg@openwrt.org>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU General Public License version 2 as published
|
||||
@ -84,6 +84,7 @@ extern unsigned long adm5120_mach_type;
|
||||
#define MACH_ADM5120_BR6104KP 42 /* Edimax BR-6104KP */
|
||||
#define MACH_ADM5120_BR61X4WG 43 /* Edimax BR-6104Wg/BR-6114WG */
|
||||
#define MACH_ADM5120_PMUGW 44 /* Motorola Powerline MU Gateway */
|
||||
#define MACH_ADM5120_5GXI 45 /* OSBRiDGE 5GXi/5XLi */
|
||||
|
||||
/*
|
||||
* TODO:remove adm5120_eth* variables when the switch driver will be
|
||||
|
@ -105,6 +105,13 @@
|
||||
# define CONFIG_USE_UART1 1
|
||||
#endif
|
||||
|
||||
/*
|
||||
* OSBRiDGE boards
|
||||
*/
|
||||
#if defined(CONFIG_BOARD_5GXI)
|
||||
# define CONFIG_BOARD_NAME "OSBRiDGE 5GXi"
|
||||
#endif
|
||||
|
||||
/*
|
||||
* ZyXEL boards
|
||||
*/
|
||||
|
@ -32,7 +32,7 @@
|
||||
source "arch/mips/emma/Kconfig"
|
||||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -176,6 +176,21 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
|
||||
@@ -183,6 +183,22 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
|
||||
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
|
||||
|
||||
#
|
||||
@ -46,6 +46,7 @@
|
||||
+core-$(CONFIG_ADM5120_OEM_INFINEON) += arch/mips/adm5120/infineon/
|
||||
+core-$(CONFIG_ADM5120_OEM_MIKROTIK) += arch/mips/adm5120/mikrotik/
|
||||
+core-$(CONFIG_ADM5120_OEM_MOTOROLA) += arch/mips/adm5120/motorola/
|
||||
+core-$(CONFIG_ADM5120_OEM_OSBRIDGE) += arch/mips/adm5120/osbridge/
|
||||
+core-$(CONFIG_ADM5120_OEM_ZYXEL) += arch/mips/adm5120/zyxel/
|
||||
+cflags-$(CONFIG_ADM5120) += -I$(srctree)/arch/mips/include/asm/mach-adm5120
|
||||
+load-$(CONFIG_ADM5120) += 0xffffffff80001000
|
||||
|
@ -32,7 +32,7 @@
|
||||
source "arch/mips/jazz/Kconfig"
|
||||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -181,6 +181,21 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
|
||||
@@ -181,6 +181,22 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
|
||||
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
|
||||
|
||||
#
|
||||
@ -46,6 +46,7 @@
|
||||
+core-$(CONFIG_ADM5120_OEM_INFINEON) += arch/mips/adm5120/infineon/
|
||||
+core-$(CONFIG_ADM5120_OEM_MIKROTIK) += arch/mips/adm5120/mikrotik/
|
||||
+core-$(CONFIG_ADM5120_OEM_MOTOROLA) += arch/mips/adm5120/motorola/
|
||||
+core-$(CONFIG_ADM5120_OEM_OSBRIDGE) += arch/mips/adm5120/osbridge/
|
||||
+core-$(CONFIG_ADM5120_OEM_ZYXEL) += arch/mips/adm5120/zyxel/
|
||||
+cflags-$(CONFIG_ADM5120) += -I$(srctree)/arch/mips/include/asm/mach-adm5120
|
||||
+load-$(CONFIG_ADM5120) += 0xffffffff80001000
|
||||
|
@ -3,6 +3,7 @@ CONFIG_32BIT=y
|
||||
# CONFIG_8139TOO is not set
|
||||
CONFIG_ADM5120=y
|
||||
CONFIG_ADM5120_ENET=y
|
||||
CONFIG_ADM5120_MACH_5GXI=y
|
||||
CONFIG_ADM5120_MACH_BR_6104K=y
|
||||
CONFIG_ADM5120_MACH_BR_6104KP=y
|
||||
CONFIG_ADM5120_MACH_BR_61X4WG=y
|
||||
@ -28,6 +29,7 @@ CONFIG_ADM5120_OEM_EDIMAX=y
|
||||
CONFIG_ADM5120_OEM_INFINEON=y
|
||||
CONFIG_ADM5120_OEM_MIKROTIK=y
|
||||
CONFIG_ADM5120_OEM_MOTOROLA=y
|
||||
CONFIG_ADM5120_OEM_OSBRIDGE=y
|
||||
# CONFIG_ADM5120_OEM_ZYXEL is not set
|
||||
CONFIG_ADM5120_SOC_BGA=y
|
||||
CONFIG_ADM5120_WDT=y
|
||||
|
@ -2,6 +2,7 @@ CONFIG_32BIT=y
|
||||
# CONFIG_64BIT is not set
|
||||
CONFIG_ADM5120=y
|
||||
CONFIG_ADM5120_ENET=y
|
||||
CONFIG_ADM5120_MACH_5GXI=y
|
||||
CONFIG_ADM5120_MACH_BR_6104K=y
|
||||
CONFIG_ADM5120_MACH_BR_6104KP=y
|
||||
CONFIG_ADM5120_MACH_BR_61X4WG=y
|
||||
@ -27,6 +28,7 @@ CONFIG_ADM5120_OEM_EDIMAX=y
|
||||
CONFIG_ADM5120_OEM_INFINEON=y
|
||||
CONFIG_ADM5120_OEM_MIKROTIK=y
|
||||
CONFIG_ADM5120_OEM_MOTOROLA=y
|
||||
CONFIG_ADM5120_OEM_OSBRIDGE=y
|
||||
# CONFIG_ADM5120_OEM_ZYXEL is not set
|
||||
CONFIG_ADM5120_SOC_BGA=y
|
||||
CONFIG_ADM5120_WDT=y
|
||||
|
16
target/linux/adm5120/router_le/profiles/Osbridge.mk
Normal file
16
target/linux/adm5120/router_le/profiles/Osbridge.mk
Normal file
@ -0,0 +1,16 @@
|
||||
#
|
||||
# Copyright (C) 2007-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
define Profile/5GXI
|
||||
NAME:=Osbridge 5GXi/5XLi (Unofficial)
|
||||
endef
|
||||
|
||||
define Profile/5GXI/Description
|
||||
Package set optimized for the OSBRiDGE 5GXi/5XLi boards.
|
||||
endef
|
||||
|
||||
$(eval $(call Profile,5GXI))
|
Loading…
Reference in New Issue
Block a user