1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 21:38:54 +03:00

tools/quilt: fix openSUSE/patch-2.6.1.81 issue (closes #7635)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22397 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
acoul 2010-07-27 17:21:30 +00:00
parent 3c05ba2472
commit f80d70ea21
2 changed files with 12 additions and 0 deletions

View File

@ -16,6 +16,7 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
include $(INCLUDE_DIR)/host-build.mk
define Host/Configure
cd $(HOST_BUILD_DIR) && autoconf
$(call Host/Configure/Default)
[ -f $(HOST_BUILD_DIR)/Makefile ]
endef

View File

@ -0,0 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
@@ -274,7 +274,7 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
+ test $2 == "patch" && patch_version=$3 || patch_version=$2
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version