1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 18:08:53 +03:00

[package] wireless-tools: fix a bug in iwconfig power command

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16491 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2009-06-17 14:42:24 +00:00
parent 53634c2d05
commit fdf0499fff
2 changed files with 14 additions and 1 deletions

View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wireless-tools
PKG_VERSION:=29
PKG_MINOR:=
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=wireless_tools.$(PKG_VERSION)$(PKG_MINOR).tar.gz
PKG_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux

View File

@ -0,0 +1,13 @@
--- a/iwconfig.c
+++ b/iwconfig.c
@@ -1034,8 +1034,8 @@ set_power_info(int skfd,
wrq.u.power.disabled = 0;
/* Is there any value to grab ? */
- value = strtod(args[0], &unit);
- if(unit != args[0])
+ value = strtod(args[i], &unit);
+ if(unit != args[i])
{
struct iw_range range;
int flags;