mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:02:49 +02:00
be01bc2bd6
directory. Add some early_printk debugging to the lzma decompressor to help track down problems when upgrading from one kernel version to another git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11627 3c298f89-4303-0410-b956-a3cf2f4a3e73
64 lines
1.9 KiB
Diff
64 lines
1.9 KiB
Diff
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -172,4 +172,9 @@
|
|
quiet_cmd_gzip = GZIP $@
|
|
cmd_gzip = gzip -f -9 < $< > $@
|
|
|
|
-
|
|
+# LZMA
|
|
+#
|
|
+quiet_cmd_lzma = LZMA $@
|
|
+cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0
|
|
+# to use lzmacomp,
|
|
+# cmd_lzma = lzmacomp $< 700 > $@
|
|
--- /dev/null
|
|
+++ b/scripts/lzma_kern
|
|
@@ -0,0 +1,4 @@
|
|
+get-size() { echo "$5" ;}
|
|
+printf -v len '%.8x' "$(get-size $(ls -l "$1"))"
|
|
+lzma e "$@"
|
|
+echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2"
|
|
--- a/arch/x86/boot/compressed/Makefile
|
|
+++ b/arch/x86/boot/compressed/Makefile
|
|
@@ -4,7 +4,7 @@
|
|
# create a compressed vmlinux image from the original vmlinux
|
|
#
|
|
|
|
-targets := vmlinux vmlinux.bin vmlinux.bin.gz head_$(BITS).o misc.o piggy.o
|
|
+targets := vmlinux vmlinux.bin vmlinux.bin.lzma head_$(BITS).o lzma_misc.o piggy.o
|
|
|
|
KBUILD_CFLAGS := -m$(BITS) -D__KERNEL__ $(LINUX_INCLUDE) -O2
|
|
KBUILD_CFLAGS += -fno-strict-aliasing -fPIC
|
|
@@ -18,7 +18,7 @@
|
|
LDFLAGS := -m elf_$(UTS_MACHINE)
|
|
LDFLAGS_vmlinux := -T
|
|
|
|
-$(obj)/vmlinux: $(src)/vmlinux_$(BITS).lds $(obj)/head_$(BITS).o $(obj)/misc.o $(obj)/piggy.o FORCE
|
|
+$(obj)/vmlinux: $(src)/vmlinux_$(BITS).lds $(obj)/head_$(BITS).o $(obj)/lzma_misc.o $(obj)/piggy.o FORCE
|
|
$(call if_changed,ld)
|
|
@:
|
|
|
|
@@ -44,11 +44,11 @@
|
|
$(call if_changed,relocbin)
|
|
|
|
ifdef CONFIG_RELOCATABLE
|
|
-$(obj)/vmlinux.bin.gz: $(obj)/vmlinux.bin.all FORCE
|
|
- $(call if_changed,gzip)
|
|
+$(obj)/vmlinux.bin.lzma: $(obj)/vmlinux.bin.all FORCE
|
|
+ $(call if_changed,lzma)
|
|
else
|
|
-$(obj)/vmlinux.bin.gz: $(obj)/vmlinux.bin FORCE
|
|
- $(call if_changed,gzip)
|
|
+$(obj)/vmlinux.bin.lzma: $(obj)/vmlinux.bin FORCE
|
|
+ $(call if_changed,lzma)
|
|
endif
|
|
LDFLAGS_piggy.o := -r --format binary --oformat elf32-i386 -T
|
|
|
|
@@ -60,5 +60,5 @@
|
|
endif
|
|
|
|
|
|
-$(obj)/piggy.o: $(obj)/vmlinux.scr $(obj)/vmlinux.bin.gz FORCE
|
|
+$(obj)/piggy.o: $(obj)/vmlinux.scr $(obj)/vmlinux.bin.lzma FORCE
|
|
$(call if_changed,ld)
|