mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:20:37 +02:00
05735d303b
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31474 3c298f89-4303-0410-b956-a3cf2f4a3e73
29 lines
947 B
Diff
29 lines
947 B
Diff
--- a/drivers/ata/Makefile
|
|
+++ b/drivers/ata/Makefile
|
|
@@ -88,6 +88,7 @@ obj-$(CONFIG_PATA_PCMCIA) += pata_pcmcia
|
|
obj-$(CONFIG_PATA_PALMLD) += pata_palmld.o
|
|
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
|
|
obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
|
|
+obj-$(CONFIG_PATA_RB153_CF) += pata_rb153_cf.o
|
|
obj-$(CONFIG_PATA_RB532) += pata_rb532_cf.o
|
|
obj-$(CONFIG_PATA_RZ1000) += pata_rz1000.o
|
|
obj-$(CONFIG_PATA_SAMSUNG_CF) += pata_samsung_cf.o
|
|
--- a/drivers/ata/Kconfig
|
|
+++ b/drivers/ata/Kconfig
|
|
@@ -835,6 +835,15 @@ config PATA_QDI
|
|
help
|
|
Support for QDI 6500 and 6580 PATA controllers on VESA local bus.
|
|
|
|
+config PATA_RB153_CF
|
|
+ tristate "RouterBOARD 153 Compact Flash support"
|
|
+ depends on ADM5120_MACH_RB_153
|
|
+ help
|
|
+ This option enables support for a Compact Flash connected on
|
|
+ the RouterBOARD 153.
|
|
+
|
|
+ If unsure, say N.
|
|
+
|
|
config PATA_RB532
|
|
tristate "RouterBoard 532 PATA CompactFlash support"
|
|
depends on MIKROTIK_RB532
|