1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-19 19:10:59 +03:00
openwrt-xburst/target/linux/adm5120/patches-3.3/007-adm5120_pci.patch
juhosg 05735d303b adm5120: add 3.3 support
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31474 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-04-25 12:57:33 +00:00

23 lines
713 B
Diff

--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o
ops-bcm63xx.o
obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
obj-$(CONFIG_SOC_AR724X) += pci-ath724x.o
+obj-$(CONFIG_ADM5120) += pci-adm5120.o
#
# These are still pretty much in the old state, watch, go blind.
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -1803,6 +1803,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+#define PCI_VENDOR_ID_ADMTEK 0x1317
+#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
+
#define PCI_VENDOR_ID_SIIG 0x131f
#define PCI_SUBVENDOR_ID_SIIG 0x131f
#define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000