1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 22:44:11 +03:00
openwrt-xburst/target/linux/uml/patches/002-gcc4_unfortify_source.patch
nico 46a0a72043 [uml] add a patch to disable compile-time buffer checks enabled by default on Ubuntu 8.10 and later (closes: #4826)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15119 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-04-06 16:45:10 +00:00

12 lines
396 B
Diff

--- a/arch/um/Makefile-i386
+++ b/arch/um/Makefile-i386
@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
echo $(call cc-option,-fno-unit-at-a-time); \
else echo $(call cc-option,-funit-at-a-time); fi ;)
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
+# and later
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
+
KBUILD_CFLAGS += $(cflags-y)