mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:33:08 +02:00
05735d303b
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31474 3c298f89-4303-0410-b956-a3cf2f4a3e73
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
--- a/drivers/watchdog/Kconfig
|
|
+++ b/drivers/watchdog/Kconfig
|
|
@@ -943,6 +943,18 @@ config RC32434_WDT
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called rc32434_wdt.
|
|
|
|
+config ADM5120_WDT
|
|
+ tristate "Infineon ADM5120 SoC hardware watchdog"
|
|
+ depends on WATCHDOG && ADM5120
|
|
+ help
|
|
+ This is a driver for hardware watchdog integrated in Infineon
|
|
+ ADM5120 SoC. This watchdog simply watches your kernel to make sure
|
|
+ it doesn't freeze, and if it does, it reboots your computer after a
|
|
+ certain amount of time.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module will be
|
|
+ called adm5120_wdt.
|
|
+
|
|
config INDYDOG
|
|
tristate "Indy/I2 Hardware Watchdog"
|
|
depends on SGI_HAS_INDYDOG
|
|
--- a/drivers/watchdog/Makefile
|
|
+++ b/drivers/watchdog/Makefile
|
|
@@ -122,6 +122,7 @@ obj-$(CONFIG_ATH79_WDT) += ath79_wdt.o
|
|
obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
|
|
obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
|
|
obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
|
|
+obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
|
|
obj-$(CONFIG_INDYDOG) += indydog.o
|
|
obj-$(CONFIG_JZ4740_WDT) += jz4740_wdt.o
|
|
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|