1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 20:30:13 +03:00
openwrt-xburst/target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch
juhosg a406ef4fe7 ramips: switch to 2.6.37
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26328 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-03-27 19:20:04 +00:00

27 lines
784 B
Diff

--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -930,6 +930,13 @@ config BCM63XX_WDT
To compile this driver as a loadable module, choose M here.
The module will be called bcm63xx_wdt.
+config RAMIPS_WDT
+ tristate "Ralink RT288X/RT305X Watchdog Timer"
+ depends on SOC_RT288X || SOC_RT305X
+ help
+ Hardware driver for the built-in watchdog timer on the
+ Ralink RT288X/RT305X SoCs.
+
# PARISC Architecture
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -119,6 +119,7 @@ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
# PARISC Architecture