1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-08 16:12:21 +03:00
openwrt-xburst/package/madwifi/patches/476-3.0_detection_fix.patch
hauke e6f792889d madwifi: Fix linux 3.0 detection
Allows madwifi to be built against linux 3.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27188 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-06-15 21:17:17 +00:00

26 lines
714 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -155,13 +155,15 @@ unload:
configcheck:
@echo -n "Checking kernel configuration... "
- @# check version of kernel
- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
- echo "FAILED"; \
- echo "Only kernel versions 2.4.x and above are supported."; \
- echo "You have $(KERNELRELEASE)."; \
- exit 1; \
- }
+ @# check kernel version
+ @case $(KERNELRELEASE) in \
+ 2.[456].*) ;; \
+ [3-9].*) ;; \
+ *) echo "FAILED"; \
+ echo "Only kernel versions 2.4.x and above are supported."; \
+ echo "You have $(KERNELRELEASE)."; \
+ exit 1 ;; \
+ esac
@# check kernel configuration
@if [ -z "$(CONFIG_SYSCTL)" ]; then \