1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 19:28:53 +03:00
openwrt-xburst/package/uboot-lantiq/patches/010-fix-mips-flags.patch
blogic 0ae5a76a91 [uboot-lantiq]
* add some compile flags


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26025 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-03-11 08:22:47 +00:00

26 lines
614 B
Diff

--- a/cpu/mips/config.mk
+++ b/cpu/mips/config.mk
@@ -23,17 +23,19 @@
v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
MIPSFLAGS:=$(shell \
if [ "$v" -lt "14" ]; then \
- echo "-mcpu=4kc"; \
+ echo "-mcpu=mips32"; \
else \
- echo "-march=4kc -mtune=4kc"; \
+ echo "-mips32 -march=mips32 -mtune=mips32"; \
fi)
+ifndef ENDIANNESS
ifneq (,$(findstring 4KCle,$(CROSS_COMPILE)))
ENDIANNESS = -EL
else
ENDIANNESS = -EB
endif
+endif
-MIPSFLAGS += $(ENDIANNESS)
+MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
PLATFORM_CPPFLAGS += $(MIPSFLAGS)