1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-05 03:08:34 +03:00
openwrt-xburst/tools/quilt/patches/100-patch_2.6.1_version.patch
acoul f80d70ea21 tools/quilt: fix openSUSE/patch-2.6.1.81 issue (closes #7635)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22397 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-07-27 17:21:30 +00:00

12 lines
374 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -274,7 +274,7 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
+ test $2 == "patch" && patch_version=$3 || patch_version=$2
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version