1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 16:19:53 +03:00
openwrt-xburst/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
nbd 1e0188b074 kernel: use -fno-caller-saves
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26301 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-03-26 01:07:16 +00:00

25 lines
675 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -539,9 +539,9 @@ endif # $(dot-config)
all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
-KBUILD_CFLAGS += -Os
+KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -596,6 +596,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)