mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:06:15 +02:00
e6f792889d
Allows madwifi to be built against linux 3.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27188 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
714 B
Diff
26 lines
714 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -155,13 +155,15 @@ unload:
|
|
configcheck:
|
|
@echo -n "Checking kernel configuration... "
|
|
|
|
- @# check version of kernel
|
|
- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
|
|
- echo "FAILED"; \
|
|
- echo "Only kernel versions 2.4.x and above are supported."; \
|
|
- echo "You have $(KERNELRELEASE)."; \
|
|
- exit 1; \
|
|
- }
|
|
+ @# check kernel version
|
|
+ @case $(KERNELRELEASE) in \
|
|
+ 2.[456].*) ;; \
|
|
+ [3-9].*) ;; \
|
|
+ *) echo "FAILED"; \
|
|
+ echo "Only kernel versions 2.4.x and above are supported."; \
|
|
+ echo "You have $(KERNELRELEASE)."; \
|
|
+ exit 1 ;; \
|
|
+ esac
|
|
|
|
@# check kernel configuration
|
|
@if [ -z "$(CONFIG_SYSCTL)" ]; then \
|