1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-21 02:23:16 +03:00
openwrt-xburst/toolchain/uClibc/patches/190-install_tls.patch
nbd 7cae514282 uclibc: add some libpthread fixes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14013 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-13 02:15:14 +00:00

13 lines
656 B
Diff

--- a/libpthread/linuxthreads/Makefile.in
+++ b/libpthread/linuxthreads/Makefile.in
@@ -128,7 +128,9 @@ linuxthreads_headers:
$(Q)$(LN) -sf ../$(PTDIR)/sysdeps/pthread/pthread.h $(top_builddir)include/
$(Q)$(LN) -sf ../$(PTDIR)/semaphore.h $(top_builddir)include/
$(Q)$(INSTALL) -d $(top_builddir)include/bits
+ $(Q)$(INSTALL) -d $(top_builddir)include/sys
$(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/pthread/bits/pthreadtypes.h $(top_builddir)include/bits/
+ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/$(TARGET_ARCH)/tls.h $(top_builddir)include/sys/
linuxthreads_headers_clean:
$(RM) $(top_builddir)include/pthread.h $(top_builddir)include/semaphore.h \