mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 00:40:16 +02:00
w3m: build-in image support (not without ugly hacks)
This commit is contained in:
parent
8f5504bff8
commit
2b645ddd14
19
w3m/Makefile
19
w3m/Makefile
@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=w3m
|
||||
PKG_VERSION:=0.5.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=ba06992d3207666ed1bf2dcf7c72bf58
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
define Package/w3m
|
||||
TITLE:=w3m
|
||||
@ -23,7 +24,7 @@ define Package/w3m
|
||||
SECTION:=network
|
||||
CATEGORY:=Network
|
||||
URL:=http://w3m.sourceforge.net/
|
||||
DEPENDS:=+libopenssl +gc +libncursesw
|
||||
DEPENDS:=+libopenssl +gc +libncursesw +gtk2
|
||||
endef
|
||||
|
||||
define Package/w3m/description
|
||||
@ -39,14 +40,24 @@ endef
|
||||
CONFIGURE_ARGS += --with-ssl=$(STAGING_DIR)/usr \
|
||||
--with-gc=$(STAGING_DIR)/usr/lib \
|
||||
--disable-xface \
|
||||
--with-imagelib="gtk2 gdk-pixbuf"
|
||||
--with-imagelib="gtk2" \
|
||||
--enable-image="fb"
|
||||
|
||||
CONFIGURE_VARS += ac_cv_lib_gc_GC_init=yes
|
||||
|
||||
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/glib-2.0 \
|
||||
-I$(STAGING_DIR)/usr/include/gtk-2.0 \
|
||||
-I$(STAGING_DIR)/usr/include/pango-1.0 \
|
||||
-I$(STAGING_DIR)/usr/include/cairo
|
||||
|
||||
TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
$(INTL_LDFLAGS) $(ICONV_LDFLAGS) \
|
||||
-lintl -lglib-2.0 -liconv -lgdk_pixbuf-2.0
|
||||
|
||||
define Package/w3m/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/w3m
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/w3m $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/w3mimgdisplay $(1)/usr/lib/w3m
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,w3m))
|
||||
|
12
w3m/patches/004-gdk-override.patch
Normal file
12
w3m/patches/004-gdk-override.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ur w3m-0.5.2.orig/configure w3m-0.5.2/configure
|
||||
--- w3m-0.5.2.orig/configure 2011-02-25 21:51:15.648183991 +0300
|
||||
+++ w3m-0.5.2/configure 2011-02-25 22:03:24.676058666 +0300
|
||||
@@ -5626,7 +5626,7 @@
|
||||
else
|
||||
{ echo "$as_me:$LINENO: WARNING: GdkPixbuf is not installed. Install GdkPixbuf (version >= 2.0.0)" >&5
|
||||
echo "$as_me: WARNING: GdkPixbuf is not installed. Install GdkPixbuf (version >= 2.0.0)" >&2;}
|
||||
- have_gdkpixbuf="no"; have_gtk2="no"
|
||||
+ have_gdkpixbuf="yes"; have_gtk2="yes"
|
||||
fi
|
||||
fi
|
||||
if test x"$with_gdkpixbuf" = xyes; then
|
Loading…
Reference in New Issue
Block a user